Mengatasi Error Ojs 3.1 Api Error

By | Februari 14, 2020

Pengalaman sebagai editor jurnal yang memakai ojs 3 ada beberapa pengalaman error menyerupai arikel sebelumnya adalah login selalu ditolak saat memakai operator internet milik BUMN, kali ini akan aku bahas mengenai dilema yang mengalami dilema error menyerupai ini ##api.submissions.unknownError##. 

atau menerima dilema error menyerupai dibawah ini

Error yang terjadi diatas sanggup dicek terlebih dahulu pada detail log, misalnya menyerupai berikut:

[Wed Nov 01 10:39:18.495940 2017] [:error] [pid 9018] [client IP] PHP Parse error: syntax error, unexpected ‘class’ (T_CLASS), expecting identifier (T_STRING) or variable (T_VARIABLE) or ‘{’ or ‘$’ in /var/www/ojs3/html/lib/pkp/lib/vendor/slim/slim/Slim/Container.php on line 149, referer: http://ojs/caracol/submissions 8
[Wed Nov 01 10:39:18.496139 2017] [:error] [pid 8929] [client IP] PHP Parse error: syntax error, unexpected ‘class’ (T_CLASS), expecting identifier (T_STRING) or variable (T_VARIABLE) or ‘{’ or ‘$’ in /var/www/ojs3/html/lib/pkp/lib/vendor/slim/slim/Slim/Container.php on line 149, referer: http://ojs/caracol/submissions 8
[Wed Nov 01 10:39:18.503245 2017] [:error] [pid 8949] [client IP] PHP Parse error: syntax error, unexpected ‘class’ (T_CLASS), expecting identifier (T_STRING) or variable (T_VARIABLE) or ‘{’ or ‘$’ in /var/www/ojs3/html/lib/pkp/lib/vendor/slim/slim/Slim/Container.php on line 149, referer: http://ojs/caracol/submissions 8

Error tersebut  terjadi sebab beberapa dilema diantaranya:
1. Server tidak memenuhi minimun spesifikasi versi ojs yang digunakan
2. Melalukan update ojs yang tidak sesuai dengan kemampuan server

Solusi yang diharapkan adalah perhatikan versi ojs yang diinstall dan sesuaikan dengan versi OJS yang akan digunakan. Spesifikasi minimun yang perlu diperhatikan adalah dilema versi PHP. Pada analisa error log diatas diketahui bahwa PHP yang dipakai harus diupgrade sebab versi ojs 3.x mempunyai standat minimum sebagai berikut:

OJS 3.X
System Requirements
To run OJS 3.x, your web server will need:

Semoga bermanfaat
 

Tinggalkan Balasan

Alamat email Anda tidak akan dipublikasikan. Ruas yang wajib ditandai *